PatchaPalooza

CVE-2025-59237: Microsoft SharePoint Remote Code Execution Vulnerability

CVE-2025-59237 is a remote code execution vulnerability in Microsoft SharePoint, rated Important by Microsoft, with a CVSS 3.1 base score of 8.8 (High). An attacker can exploit it remotely over the network, with low privileges and without user interaction. Microsoft has not reported exploitation in the wild and rates exploitation as less likely. The EPSS model estimates a 2.46% probability of exploitation activity in the next 30 days, higher than 84% of all scored vulnerabilities. Microsoft released the fix on 14 October 2025 in the October 2025 Patch Tuesday, delivered through 3 security updates (KB5002788, KB5002796, KB5002786). It affects 3 products in 1 product family (Microsoft Office).

Key facts

CVE ID
CVE-2025-59237
Severity
High CVSS 8.8
Microsoft severity
Important
Impact
Remote Code Execution
Exploited in the wild
No
Publicly disclosed
No
Exploitation likelihood
Less Likely
Weakness
CWE-502
EPSS
2.46% (percentile 84%)
CISA KEV
Not listed
Released
Last updated
Patch Tuesday
October 2025 Patch Tuesday
Product families
Microsoft Office

CVSS score and vector

Microsoft scores CVE-2025-59237 at 8.8 (temporal 7.7) using CVSS 3.1. Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C

MetricValue
Attack vectorNetwork
Attack complexityLow
Privileges requiredLow
User interactionNone
ScopeUnchanged
Confidentiality impactHigh
Integrity impactHigh
Availability impactHigh
Exploit code maturityUnproven
Remediation levelOfficial fix
Report confidenceConfirmed

Description

Deserialization of untrusted data in Microsoft Office SharePoint allows an authorized attacker to execute code over a network.

Frequently asked questions (Microsoft)

How could an attacker exploit the vulnerability?

In a network-based attack, an attacker authenticated as at least a Site Owner, could write arbitrary code to inject and execute code remotely on the SharePoint Server.

I am running SharePoint Server 2016. Do the updates for SharePoint Enterprise Server 2016 also apply to the version I am running?

Yes. The same KB number applies to both SharePoint Server 2016 and SharePoint Enterprise Server 2016. Customers running either version should install the security update to be protected from this vulnerability.

According to the CVSS metric, privileges required is low (PR:L). What does that mean for this vulnerability?

Any authenticated attacker could trigger this vulnerability. It does not require admin or other elevated privileges.

Affected products (3)

Microsoft Office

ProductSecurity updateTypeFixed buildRestart
Microsoft SharePoint Enterprise Server 2016KB5002788Security Update16.0.5522.1000Maybe
Microsoft SharePoint Server 2019KB5002796Security Update16.0.10417.20059Maybe
Microsoft SharePoint Server Subscription EditionKB5002786Security Update16.0.19127.20262Maybe

Security updates (3)

NIST NVD data

NVD status
Analyzed
NVD CVSS
8.8 (HIGH)
NVD weakness
CWE-502
Published to NVD
NVD last modified

Affected configurations (CPE)

ProductVulnerable versions
sharepoint serverbefore 16.0.19127.20262
sharepoint server 2016all listed versions
sharepoint server 2019all listed versions

References

Revision history

VersionDateDescription
1.0Information published.

Sources